Qt packaging changes in maemo.org extras-devel

0
0
2010-04-22 12:50 UTC by Attila Csipa

One of the big changes PR1.2 brought us is official Qt support in the form of Q4.6 in the Nokia SDK and repositories. This change affects all applications depending on Qt currently in extras-devel. We had some talks with Qt/Nokia folks about Qt-related repository changes in Maemo 5 (triggered by aforementioned PR1.2 and potentially again later on by updates to Qt or related components).

 

Here is the short summary:

 

1. remove qt4-maemo5 (4.6) after PR1.2

2. upload Qt 4.7 snapshots as qt4-experimental to extras-devel afterwards

3. as soon as 4.6 QtMobility is released, get those packages to the nokia-apps repository

4. remove 4.6 QtMobility from extras-devel

5. maybe upload new QtMobility packages to extras-devel, but only for qt4-experimental (4.7) and with 'experimental' in the package name

6. maintainers of bindings and extensions to Qt are encouraged to follow the same nomenclature in their package names (i.e. using experimental in the name if depending on qt4-experimental)

7. use a Provides/Replaces/etc libqt4-maemo5 clause in the qt4-experimental packages (Qt4.7 packages should be binary compatible with the current 4.6 ones) so the packages can be deprecated peacefully

8. QML/declarative will be released as part of Qt4.7 (so qt4-experimental only, no 4.6.2/PR1.2 support)

 

Have a nice day !

Comments:

HeartJ Jiang
Karma: 5

Which package should be installed before I install my app. thx.

2010-04-24 08:05 UTC
Attila Csipa
Karma: 1430

The change affects only libqt4-maemo5-* packages. If you were using libqt4-dev, you don't need to change anything in the control files.

2010-04-24 04:42 UTC

What packages do we need to have in the debian/control file for the autobuilder to work? At the moment I have the following line. Build-Depends: debhelper (>= 5), libqt4-dev

Thanks

2010-04-23 23:47 UTC
Attila Csipa
Karma: 1430

These are the procedurea that will be done by the Qt package maintainers. If you're a user, you don't need to do anything. If you're a developer, and have packages depending on libqt4-maemo5, note that those package names are deprecated. After PR1.2, use libqt4-experimental-* if you need Qt4.7 features, or libqt4-* if you want Qt4.6. Qt4.5 will no longer be supported after the release of PR1.2

2010-04-23 15:13 UTC
Chealy Te
Karma: 12

hmm i am confused .. this is for def-extra only or this is step for us to do to test .. or those 8 step are automatically done by script .. ..

2010-04-23 14:54 UTC
Ivan De Marino
Karma: 22

When man? Wheeeeen? :(

2010-04-23 07:27 UTC

Comments:

You must be logged in to make comments.

Back